导火索

在启动一个前端项目的时候,
我是先安装了nodejs
然后又安装nvm,发现报错,一直弹出是否用nvm管理npm版本,
然后索性就把nodejs卸载了,
先安装了nvm,用

nvm install 16.16.0

安装了nodejs

问题

问题1


这个问题是因为没有权限,要用管理员身份打开cmd

问题2

在解决上个问题之后,
执行npm install

不是这样卡死就是报错

npm ERR! gyp ERR! find VS not looking for VS2013 as it is only supported up to Node.js 8

我以为这样安装一下visual studio就解决了,但是,并没有,安装了visual studio2017也无法解决,还是报错同样的问题
其间还用了cnpm pnpm都不行,
我试过-》这篇文章,点击访问这位老哥《-
安装了,也不能解决。

期间出现过报错

npm ERR! Error: getaddrinfo ENOTFOUND npm.taobao.org

以及nuxt.js找不到的问题,还有cross-env找不到的问题

仔细回想了一下,它提示过我npm install -g npm@8.15.0
好像是这里的问题
重新卸载一下nvm uninstall 16.16.0
再执行nvm install 16.16.0
再安装依赖就解决了

分类: 前端

1 条评论

sfgh · 2022-08-12 22:47

bbbbbbbbbbbbbbb

评论已关闭。

站点统计

  • 文章总数:309 篇
  • 分类总数:19 个
  • 标签总数:191 个
  • 运行天数:1006 天
  • 访问总数:124289 人次

浙公网安备33011302000604

辽ICP备20003309号